Gemalto is now part of the Thales Group, find out more.

You are here

EHS6T - CSD dial-in data connection is not working | Thales IoT Developer Community

November 26, 2014 - 4:07pm, 7077 views

Hello

We are trying to establish a CSD (Circuit Switched Data) dial-up line to an EHS6T USB modem (FW Rev. 2.0).

We have one SIM card that is enabled for CSD dial-out and another SIM card that is enabled for CSD dial-in connections. If we insert the SIM card for CSD dial-in into the EHS6T and dial-up to it from another modem with the SIM card for CSD dial-out we get "NO CARRIER" all the time.

If however we switch the SIM cards, so the EHS6T is the one dialing out to another modem (In our case a Gemalto BGS2T) then we get "CONNECT 9600" and hence a fine CSD line.

We have tried with another SIM card where we actually got "RING..RING..RING" on the EHS6T but without the modem taken the call? Also if we call the EHS6T modem using a normal mobile phone it will say "RING..RING..RING".

Is this purely SIM card related and hence Tele provider related or is there some specific AT settings we should be aware of for the EHS6T ?

We are using the USB connection on the EHS6T with a Linux system and ttyATM0, 115200baud, 8N1, RTS/CTS hardware handshaking.

We have following AT settings:

AT&D0

AT+CBST=0,0,1 (Also tried 7,0,1 and 71,0,1 with same result)

ATS0=1 (Also tried ATS0=2 with same result)

ATX4 (Also tried ATX0 and ATX3 with same result)

AT+CPIN="****" (Our specific pin code for the SIM card to enable the SIM card)

We use ATD******** to dial the number. We have tried both with and with-out country code prefix eg. 0045.

Kind regards

Per Hungeberg Møller

ROMO Wind.