Gemalto is now part of the Thales Group, find out more.

You are here

Cinterion PLS8-X only connects to 2G networks | Thales IoT Developer Community

March 30, 2016 - 5:44pm, 3042 views

I am using the PSL8-X in a Android embedded product, using the propetary Gemalto RIL. It is working fine, but I am unable to connect to 3G o 4G networks.

I am ussing the PHS8_Adapter, with the same jumper configuration as shown here: http://www.acte-uk.com/files/7313/9601/9356/PHS8_Adapter_bd.jpg. I have connected the antenna to the right most connector.

After debugging the issue for a while, it seems like the modem itself is only detecting 2G networks. I verified that the AT+WS46 is 25 (3GPP Systems, GERAN, UTRAN and E-UTRAN), but issuing AT+COPS=? only returns 2G networks.

I have tried to change the value of AT+WS46 setting: the modem answers AT OK, but the setting is unchanged.

This is the output on a session on a linux box, without any other process interfering, trying to somehow detect other networks (no 2G):

----------------------------------------------------

root@box:~# microcom /dev/ttyACM1

AT+WS46?

ERROR

AT+COPS=?

+COPS: (2,"vodafone ES","vodafone ES","21401",0),(3,"Orange SP","ESPRT","21403",0),(3,"YOIGO","YOIGO","21404",0),(3,"Movistar","Movistar","21407",0),,(0,1,2,3,4),(0,1,2)

OK

AT+WS46?

+WS46: 12

OK

AT+WS46=25

OK

AT+WS46

ERROR

AT+WS46?

ERROR

AT+COPS=0

ERROR

AT+COPS=0

OK

AT+COPS?

+COPS: 0

OK

AT+COPS=?

ERROR

AT+COPS=?

+COPS: (2,"vodafone ES","vodafone ES","21401",0),(3,"Orange SP","ESPRT","21403",0),(3,"YOIGO","YOIGO","21404",0),(3,"Movistar","Movistar","21407",0),,(0,1,2,3,4),(0,1,2)

OK

^SSTN: 137

AT+WS46?

+WS46: 25

OK

AAAT+COPS=?

+COPS: (2,"vodafone ES","vodafone ES","21401",0),(3,"Orange SP","ESPRT","21403",0),(3,"YOIGO","YOIGO","21404",0),(3,"Movistar","Movistar","21407",0),,(0,1,2,3,4),(0,1,2)

OK

AT+WS46?

+WS46: 25

OK

AT+COPS=0,,,2

OK

AT+WS46?

+WS46: 22

OK

AT+COPS?

+COPS: 0

OK

AT+COPS=?

+COPS: (1,"vodafone ES","voda ES","21401",0),(3,"YOIGO","YOIGO","21404",0),(3,"Movistar","Movistar","21407",0),(3,"Orange SP","ESPRT","21403",0),,(0,1,2,3,4),(0,1,2)

OK

AT+COPS=0,,,7

OK

AT+COPS=?

+COPS: (1,"vodafone ES","voda ES","21401",0),(3,"Orange SP","ESPRT","21403",0),(3,"Movistar","Movistar","21407",0),(3,"YOIGO","YOIGO","21404",0),,(0,1,2,3,4),(0,1,2)

OK

AT+WS46=?

+WS46: (12,22,25,28,29)

OK

AT+WS46?

+WS46: 28

----------------------------------------------------

Using other cellular modems in the same place with the same SIM card works on 2G, 3G and 4G networks, so I have discarded those factors.

1- Is there any other AT command which may be necessary in order to make the modem detect 3G and 4G networks?

2- Where can I find the AT Command Set document for the Cinterion PLS8-X?

3- Could this be caused by using a worng/bad quality antenna?

Thanks