Gemalto is now part of the Thales Group, find out more.

You are here

mPLS62-W: Two issues | Thales IoT Developer Community

July 21, 2020 - 7:28am, 844 views

Hello there,

we eventuelly want to connect a mPLS62-W to the internal USB of an upcoming embedded Linux product, and we are currently in the proof-of-concept phase. At the moment we have two issues with the mPLS62-W.

Issue one is that there is no stable connection with the mPLS62-W.

We are using an external "Mini PCI-E to USB Adapter" (sorry, I don't know the make or model, the quoted text is all the information given on the PCB) and two LTE atennas attached to the "Main" and "DIV ANT" connectors of the mPLS62-W.

When we noticed the first connection problems, we implemented a loop to constantly issue AT^SMONI after the initial setup.

It seems that the first six or so responses include "CONN" (but never long enough for one of the cdc_ether ports to get a link), while it's mostly "NOCONN" afterwards (as in, the longer the loop runs the more the connection ratio tends to 1%). The signal strength is always below -100, while the signal quality ranges from good to fair. An LTE smartphone at the the same location seems to work fine.

SMONI: 4G,1600,3,15,15,FDD,262,03,E4FD,1389019,42,13,-110,-12.0,NOCONN

We were suspecting an issue with the USB adapter and tried to use an older embedded PC with a Mini PCIe slot that already had a modem card with a PHS8-P.

And here is the second issue, the mPLS62-W is not recognised in the Mini PCIe slot at all.

Here is the "dmesg" log with the mPLS62-W in the external adapter and the PHS8-P in the internal Mini PCIe slot to prove that it works (PHS8-P is recognised by usbserial and the option driver, while mPLS62-W works with the cdc_acm driver):

[    6.383068] usb 1-1.2: device descriptor read/64, error -110

[    6.581753] usb 1-1.2: New USB device found, idVendor=1e2d, idProduct=005b

[    6.581776] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0

[    6.581783] usb 1-1.2: Product: PLSx

[    6.581788] usb 1-1.2: Manufacturer: Cinterion Wireless Modules

[    6.614551] cdc_acm 1-1.2:1.0: ttyACM0: USB ACM device

[    6.617124] cdc_acm 1-1.2:1.2: ttyACM1: USB ACM device

[    6.619824] cdc_acm 1-1.2:1.4: ttyACM2: USB ACM device

[    6.622430] cdc_acm 1-1.2:1.6: ttyACM3: USB ACM device

[    6.625009] cdc_acm 1-1.2:1.8: ttyACM4: USB ACM device

[    6.632465] cdc_ether 1-1.2:1.10 usb0: register 'cdc_ether' at usb-0000:00:1d.0-1.2, CDC Ethernet Device, fa:96:11:12:13:14

[    6.638675] cdc_ether 1-1.2:1.12 usb1: register 'cdc_ether' at usb-0000:00:1d.0-1.2, CDC Ethernet Device, fa:96:11:12:13:16

[    6.659578] cdc_ether 1-1.2:1.10 enp0s29u1u2i10: renamed from usb0

[    6.665943] cdc_ether 1-1.2:1.12 enp0s29u1u2i12: renamed from usb1

...

[   13.343038] usb 1-1.3: new high-speed USB device number 4 using ehci-pci

[   13.432381] usb 1-1.3: New USB device found, idVendor=1e2d, idProduct=0053

[   13.432391] usb 1-1.3: New USB device strings: Mfr=3, Product=2, SerialNumber=0

[   13.432398] usb 1-1.3: Product: PH8

[   13.432403] usb 1-1.3: Manufacturer: Cinterion

[   13.435131] option 1-1.3:1.0: GSM modem (1-port) converter detected

[   13.435536] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB0

[   13.436267] option 1-1.3:1.1: GSM modem (1-port) converter detected

[   13.436489] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB1

[   13.437174] option 1-1.3:1.2: GSM modem (1-port) converter detected

[   13.437398] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB2

[   13.438103] option 1-1.3:1.3: GSM modem (1-port) converter detected

[   13.438330] usb 1-1.3: GSM modem (1-port) converter now attached to ttyUSB3

"lsusb" also shows both modems are found on the USB:

Bus 001 Device 004: ID 1e2d:0053  # PH8

Bus 001 Device 003: ID 1e2d:005b  # PLSx

Bus 001 Device 002: ID 8087:07e6

Bus 001 Device 001: ID 1d6b:0002  # EHCI Host Controller

When the modem cards switch places, i.e. PHS8-P is in the external adapter while mPLS62-W is in the internal Mini PCIe slot, only the older PHS8-P is found:

[   13.355774] usb 1-1.2: new high-speed USB device number 3 using ehci-pci

[   13.448348] usb 1-1.2: New USB device found, idVendor=1e2d, idProduct=0053

[   13.448358] usb 1-1.2: New USB device strings: Mfr=3, Product=2, SerialNumber=0

[   13.448364] usb 1-1.2: Product: PH8

[   13.448369] usb 1-1.2: Manufacturer: Cinterion

[   13.451301] option 1-1.2:1.0: GSM modem (1-port) converter detected

[   13.451639] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB0

[   13.452289] option 1-1.2:1.1: GSM modem (1-port) converter detected

[   13.452625] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB1

[   13.453254] option 1-1.2:1.2: GSM modem (1-port) converter detected

[   13.453572] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB2

[   13.454218] option 1-1.2:1.3: GSM modem (1-port) converter detected

[   13.454557] usb 1-1.2: GSM modem (1-port) converter now attached to ttyUSB3

"lsusb" also shows that the mPLS62-W is not found on the USB when in the Mini PCIe slot:

Bus 001 Device 003: ID 1e2d:0053  # PH8

Bus 001 Device 002: ID 8087:07e6

Bus 001 Device 001: ID 1d6b:0002  # EHCI Host Controller

We know that they use different drivers, so there might be a different issue as well, but we would at least expect the mPLS62-W to be found by the USB core driver, when the Mini PCIe slot seems to work fine for the PHS8-P.

Thanks in advance for any hint that might solve this problem.