Gemalto is now part of the Thales Group, find out more.

You are here

PXS8 Sporadically Powers Off | Thales IoT Developer Community

September 9, 2020 - 10:47pm, 548 views

Hello,

We have a number of PXS8 modules on the CDMA Sprint network. After an indeterminate interval (anywhere from 2 to 32 hours), some of the modules begin to shut off. Several of the modules are most prone to this behavior, while others are less likely to power off, and some do not exhibit this behavior at all. Two modules in particular usually shut off within a few seconds of each other. I can restore each module by toggling the IGT line.

Here are some more details that I have gathered:

  • I disabled AT^SCFG="MEShutdown/OnIgnition", but the problem persists.
  • The shutdowns do not appear to be caused by an under/over voltage or temperature. (To my knowledge, no URC is received to indicate either of these scenarios.)
  • The power supply does not appear to be the issue. Several modules are powered with the same supply.
  • I am using the default configuration of AT^SDPORT=6. When a module powers off, the host device logs that the USB connection was removed. A few seconds later, it sees the USB connection again and treats it as a new device. A few seconds after this, the USB connection is removed again.
  • The failures do not occur at a consistent time of the day.
  • All modules have the same firmware revision: 03.320.

Please let me know if anyone has an idea of what might be causing this.

Thanks,

Christopher