Gemalto is now part of the Thales Group, find out more.

You are here

Migrating Midlets bettwen moduels and FW versions

Documentation, January 20, 2020 - 12:08pm, 2091 views

Hi,

this article will try to guide youe to build a single midlet that will be able to be execute in several Java modules and FW versions

Differences between EHSx R3/ELS61 R1/BGS5 and EHSx R4/ ELS61 R2/PLS62

1)For EHSx R3/ELS61 R1/BGS5 adding explicitly cwmlib_1.0.jar is required. For EHSx R4/ ELS61 R2/PLS62 "cwmlib_1.0.jar"library is "no longer needed". the library is included in the FW

2)API differences:

===A.New APIs added for EHSx R4/ ELS61 R2/PLS62:===

LWM2M
CoAP
JRC ATCommand (JAT)


===B.Classes and Interfaces removed in EHSx R4/ ELS61 R2/PLS62:===
Control, Controllable Manager Media, Exception Player, PlayerListener, PushRegistry ToneControl, VolumeControl

===In case you are using MQTT===

Please use the last published sources availables in the Forum

Status 12/19

https://developer.gemalto.com/showcase/paho-project-110-july-2016-mqtt-311

Summary It is possible to build a Java application, which will work for  EHSx R3/ELS61 R1/BGS5 and EHSx R4/ ELS61 R2/PLS623. It should be built with R3 WTK and R3 cwmlib_1.0.jar added, and with cwmlib_1.0 not obfuscated.* Please read the article of CWMLIB_1.0.jar for details how to proceed during the development steps

https://developer.gemalto.com/documentation/cwmlib10jar

Regards

EPT TEam

Tero's picture
Tero

Hi,

How can you use both R3 and R4 WTK with the same computer and possibly with the same Eclipse, If you either want to use EHSx R4's new API or you find at some point that everything doesn't work in EHSx R4 as it worked in R3 (like tz addition in +CCLK response in R4) and you need to make software for older R3 too?

I think that both WTKs want to get installed to the same place.

Alopez

Contributors

Profile Picture
esander
Profile Picture
Craig
Profile Picture
leon.weng
Profile Picture
Dariusz
Profile Picture
Florian.Hinrichs
Alex Shvarts
ASHVARTS