Gemalto is now part of the Thales Group, find out more.

You are here

SensorLogic Web Service API Reference - Version 5.0

Documentation, July 2, 2014 - 1:18pm, 3119 views

SensorLogic Web Services API.

Downloads

Please Log in or register to download the files.

aamal's picture
aamal

Authentication failure when trying to get the list of devices. We build the signature as explained in the documentation but this fails all the time.
The requests that we sent are :
1- get server time : https://api.sensorlogic.com/v5.0/tools/time
2 - get signature using the API
3 - get the list of devices
The last request returns :

Authentication failed.

Thnx

ejobin's picture
ejobin

It seems you have a error in the way you format the API to get the device list

you format witha list.xml

Liste des Devices : https://api.sensorlogic.com/v5.0/device/list.xml?authOrg=ALTEN&authUser=...

and you shoul format without the .xml

Liste des Devices : https://api.sensorlogic.com/v5.0/device/list?authOrg=ALTEN&authUser=alte...

I hope that solve your issue.

Regards
Eric

aamal's picture
aamal

Hi,
I tested the URL without ".xml" and I got the same response.

Any idea ?

Regards,

Aziz

Fabien's picture
Fabien

Hi Aziz,

The URL is not the right one for your account, I've sent you the right by email.

Kind Regards,
/Fabien

nabdanet's picture
nabdanet

Were you able to solve it in the end? If so, could you please state how? I'm having the same problem (the response is always Authentication failed).

Thanks!

aamal's picture
aamal

Hi,

I'm getting this error message when I try to display device in the SL portal :
Failed to get device state by id '93486fa2-496d-11e4-90ea-005056aa04c5' , SDPFailedResponse[errorCode=SL-PORTAL-210,errorMsg=SDP response NULL or EMPTY.,errorCause=]

Any idea about this problem ?

Regards,

Aziz AMAL

Jędrzej Gemalto Moderator