Gemalto is now part of the Thales Group, find out more.

You are here

Multiplexer for Linux - how to detect protocol version

FAQ, March 11, 2016 - 9:30am, 1586 views

FAQ

Multiplexer for Linux - how to detect protocol version

The multiplex mode according to the ETSI TS 101 369, "GSM 07.10 Multiplexer Protocol", enables one physical serial interface to be partitioned into several virtual channels. This allows one to take advantage of several simultaneous sessions running on one serial interface.Gemalto M2M is providing a multiplex driver for Linux as source code offering multiplexer functionality by adding virtual tty ports to a Linux system. Via these virtual tty ports a Gemalto M2M module with multiplex functionality can be accessed from multiple instances through a single hardware tty port at the same time.The multiplex protocol uses an internal version control. Higher versions of the multiplex protocol are supporting additional features and are better performance and data rates can be expected.During startup of the multiplex mode the maximal possible version supported by the driver and the module is negotiated. Module and driver are negotiating the optimal protocol version to be used automatically.Please note that newer Gemalto M2M modules do not support multiplex protocol versions below 4.This is indicated by the module throwing a message if e.g. version 3 is requested by the driver:
  • “DO NOT USE MUX PROTOCOL <V4 IN THIS PRODUCT”
 To check the negotiation process, enable the trace mask on the Linux machine:
  • linmuxcfg -m=0x000000FF
and check the syslog:
  • kernel: [ 7682.090432] LinMux:  Protocol-Version: Requested: 4, Supported: 4, Used: 4
Also, you may pull for the protocol version using this command:
  • 'linmuxcfg' –v
And set the protocol version manually using this command:
  • 'linmuxcfg' -v=4
-----------------------------------------P.S. with a special thanks to Mr. Rutkowski 
Deepanraj's picture
Deepanraj

How to set default serial port in this driver?

What is the Instance which it is creating?

What settings need to be done in Linux other than linmux driver?

Will this driver be compatible with my linux 3.10.53 version ?

Will this driver only work if there is hardware flow control ?

Thank you,

Deepanraj.A

Zeljko