Gemalto is now part of the Thales Group, find out more.

You are here

EHS5 debug problem | Thales IoT Developer Community

Alexey

July 31, 2017 - 9:25pm, 1664 views

Hello.
I have a problem with ehs5 aka Cinterion.
It's been almost 3 days of my struggling with it.
I managed to control it with AT commands via com port but i want to deploy and debug my middlets.
I couldn't find manual for EHS5.
0.Do you have any open docs at your site?
I followed manual in "Java User's Guide" version: 01 for BGS5 (Can't find for EHS5. ).
Windows7x64 + jdk1.7.0_25(32bit)
Switch off windows firewall.
I Setup eclipse Juno, setup cinterion SDK which added plugin to eclipse.
And after that I tried to debug "Hello world" example without success.
I can open module in windows explorer via port.
I can send AT commands via port.
I can not debug with eclipse or netbeans.
1.Do I do something wrong? Please, point it out.

here what ^SCFG? command returns"
^SCFG: "Audio/Loop","0" 
^SCFG: "Call/Ecall/AckTimeout","5000" 
^SCFG: "Call/Ecall/Callback","0"
^SCFG: "Call/Ecall/CallbackTimeout","43200000"
^SCFG: "Call/Ecall/Msd","0000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000000000000000000"
^SCFG: "Call/Ecall/Pull****","0"
^SCFG: "Call/Ecall/SessionTimeout","20000"
^SCFG: "Call/Ecall/StartTimeout","5000"
^SCFG: "Call/ECC","0"
^SCFG: "Call/Speech/Codec","0"
^SCFG: "Gpio/****/ASC1","std"
^SCFG: "Gpio/****/DAI","gpio"
^SCFG: "Gpio/****/DCD0","gpio"
^SCFG: "Gpio/****/DSR0","gpio"
^SCFG: "Gpio/****/DTR0","gpio"
^SCFG: "Gpio/****/FSR","gpio"
^SCFG: "Gpio/****/PULSE","gpio"
^SCFG: "Gpio/****/PWM","gpio"
^SCFG: "Gpio/****/RING0","gpio"
^SCFG: "Gpio/****/SPI","rsv"
^SCFG: "Gpio/****/SYNC","gpio"
^SCFG: "GPRS/AutoAttach","enabled"
^SCFG: "Ident/Manufacturer","Cinterion"
^SCFG: "Ident/Product","EHS5-E"
^SCFG: "MEopMode/Dormancy","0","0"
^SCFG: "MEopMode/SoR","off"
^SCFG: "MEShutdown/Fso","0"
^SCFG: "MEShutdown/sVsup/threshold","0","0"
^SCFG: "Radio/Band","147"
^SCFG: "Radio/OutputPowerReduction","4"
^SCFG: "Serial/Interface/Allocation","1","1"                  
^SCFG: "Serial/USB/DDD","0","0","0409","1E2D","0058","Cinterion Wireless Modules
","EHx",""                                 
^SCFG: "Tcp/IRT","3"                     
^SCFG: "Tcp/MR","10"                  
^SCFG: "Tcp/OT","6000"       
^SCFG: "Tcp/WithURCs","on"
^SCFG: "Trace/Syslog/OTAP","0"
^SCFG: "Userware/Autostart","1"
^SCFG: "Userware/Autostart/Delay","1000"
^SCFG: "Userware/DebugInterface","0.0.0.0","0.0.0.0","0"
^SCFG: "Userware/DebugMode","on"
^SCFG: "Userware/Passwd",
^SCFG: "Userware/Stdout","null",,,,"off"                                     
^SCFG: "Userware/Watchdog","1"

here what console in Eclipse says if i chose IMP_NG_EHS5:

Using USB port COM8.
Connecting to module...
Initializing module for debugging...
Please insert a SIM and disable PIN lock.
Passing control to external device emulator...
Cannot create PortForwarder with necessary parameters: Failed to connect to device 0!
*** Error ***
Failed to connect to device 0!
Reason:
Emulator 0 terminated while waiting for it to register!
End of debug session. Emulator is closed!

here what console says if i chose IMP_NG_EHS5_REMOTE1:

Using USB port COM8.
Connecting to module...
Initializing module for debugging...
Please insert a SIM and disable PIN lock.
Passing control to external device emulator...
*** Error ***
Device "IMP_NG_EHS5_REMOTE1" not registered!
End of debug session. Emulator is closed!