Gemalto is now part of the Thales Group, find out more.

You are here

EHS6 - Can't connect to GPRS network | Thales IoT Developer Community

munishguptamg

September 29, 2015 - 3:20pm, 1834 views

Hello Everyone,

I am currently working with EHS6 and i can't connect it to GPRS network. Below is the procedure i did.

AT+CGDCONT?

+CGDCONT: 1,"IP","rcomvpn","0.0.0.0",0,0
+CGDCONT: 2,"IP","rcomvpn","0.0.0.0",0,0

OK

AT^SICS?

^SICS: 0,"conType",""
^SICS: 1,"conType","GPRS0"
^SICS: 1,"inactTO","65535"
^SICS: 1,"user","5399@ktech.com"
^SICS: 1,"passwd","*****"
^SICS: 1,"apn","rcomvpn"
^SICS: 2,"conType",""
^SICS: 3,"conType",""
^SICS: 4,"conType",""
^SICS: 5,"conType",""
OK

AT^SISS?

^SISS: 0,"srvType",""
^SISS: 1,"srvType","Socket"
^SISS: 1,"conId","1"
^SISS: 1,"address","socktcp://listener:23"
^SISS: 1,"tcpMR","10"
^SISS: 1,"tcpOT","6000"
^SISS: 2,"srvType",""
^SISS: 3,"srvType",""
^SISS: 4,"srvType",""
^SISS: 5,"srvType",""
^SISS: 6,"srvType",""
^SISS: 7,"srvType",""
^SISS: 8,"srvType",""
^SISS: 9,"srvType",""

OK


AT^SCFG?

^SCFG: "Call/ECC","0"
^SCFG: "GPRS/AutoAttach","enabled"
^SCFG: "Gpio/****/ASC1","std"
^SCFG: "Gpio/****/DAI","gpio"
^SCFG: "Gpio/****/DCD0","std"
^SCFG: "Gpio/****/DSR0","std"
^SCFG: "Gpio/****/DTR0","std"
^SCFG: "Gpio/****/FSR","gpio"
^SCFG: "Gpio/****/HSIC","rsv"
^SCFG: "Gpio/****/PULSE","gpio"
^SCFG: "Gpio/****/PWM","gpio"
^SCFG: "Gpio/****/RING0","std"
^SCFG: "Gpio/****/SPI","rsv"
^SCFG: "Gpio/****/SYNC","gpio"
^SCFG: "Ident/Manufacturer","Cinterion"
^SCFG: "Ident/Product","EHS6"
^SCFG: "MEShutdown/Fso","0"
^SCFG: "MEopMode/SoR","off"
^SCFG: "Radio/Band","511"
^SCFG: "Radio/OutputPowerReduction","4"
^SCFG: "Serial/Interface/Allocation","1","1"
^SCFG: "Serial/USB/DDD","0","0","0409","1E2D","0058","Cinterion Wireless Modules","EHx",""
^SCFG: "Tcp/IRT","3"
^SCFG: "Tcp/MR","10"
^SCFG: "Tcp/OT","6000"
^SCFG: "Tcp/WithURCs","on"
^SCFG: "Trace/Syslog/Otap","0"
^SCFG: "URC/Ringline","local"
^SCFG: "URC/Ringline/ActiveTime","2"
^SCFG: "Userware/Autostart","1"
^SCFG: "Userware/Autostart/Delay","300"
^SCFG: "Userware/DebugInterface","0.0.0.0","0.0.0.0","0"
^SCFG: "Userware/DebugMode","on"
^SCFG: "Userware/Passwd",
^SCFG: "Userware/Stdout","asc0",,,,"off"
^SCFG: "Userware/Watchdog","0"

OK

AT^SISO=1

OK

^SIS: 1,0,94,"PDP: connection failed"


AT^SICI?

^SICI: 1,0,0,"0.0.0.0"

OK