Gemalto is now part of the Thales Group, find out more.

You are here

EHS6 Socket Issues AT^SISC and AT^SISS | Thales IoT Developer Community

January 20, 2017 - 9:01pm, 4809 views

Hello to everyone!

I´m having trouble to recover after an unexpected power failure with my EHS6 V3. I´m running a Java programs that sends AT commands to the EHS6 to establish a non transparent TCP socket Client (always on).

The current set of commands it´s able to connect to the server and works fine, but if there is a sudden interruption on the power source (let's say a couple of seconds) the midlet restarts but wont receive any AT^SICS or AT^SISS commands. it returns +CME ERROR: 256 ( operation temporary not allowed ).

In the AT Command Manual says that writing "none" on the "srvType" will reset the rest of the parameters, but this command also returns the previously refered error.

I tryed to send the command AT^SISC after receiving the +CME ERROR: 256 but results in +CME ERROR: 21 (Invalid Index)

If I wait around 10 to 15 minutes and power the module up again it works fine like the first time

There is a command to force the EHS6 to release all PDP and Internet Service Configuration?

There is a command to change the local port when acting as a non transparent Socket Client?

Here is the version, config and commands that I'm sending.

Thanks in advance

ATI

Cinterion
EHS6
REVISION 03.001

OK

AT^SCFG?

^SCFG: "Audio/Loop","0"
^SCFG: "Call/ECC","0"
^SCFG: "Call/Speech/Codec","0"
^SCFG: "GPRS/AutoAttach","disabled"
^SCFG: "Gpio/****/ASC1","std"
^SCFG: "Gpio/****/DAI","gpio"
^SCFG: "Gpio/****/DCD0","gpio"
^SCFG: "Gpio/****/DSR0","gpio"
^SCFG: "Gpio/****/DTR0","gpio"
^SCFG: "Gpio/****/FSR","gpio"
^SCFG: "Gpio/****/HSIC","rsv"
^SCFG: "Gpio/****/PULSE","gpio"
^SCFG: "Gpio/****/PWM","gpio"
^SCFG: "Gpio/****/RING0","gpio"
^SCFG: "Gpio/****/SPI","rsv"
^SCFG: "Gpio/****/SYNC","gpio"
^SCFG: "Ident/Manufacturer","Cinterion"
^SCFG: "Ident/Product","EHS6"
^SCFG: "MEShutdown/Fso","0"
^SCFG: "MEShutdown/sVsup/threshold","0","0"
^SCFG: "MEopMode/CFUN","0","1"
^SCFG: "MEopMode/SoR","off"
^SCFG: "Radio/Band","511"
^SCFG: "Radio/Mtpl","0"
^SCFG: "Radio/OutputPowerReduction","4"
^SCFG: "Serial/Interface/Allocation","1","1"
^SCFG: "Serial/USB/DDD","0","0","0409","1E2D","0058","Cinterion Wireless Modules","EHx",""
^SCFG: "Tcp/IRT","3"
^SCFG: "Tcp/MR","10"
^SCFG: "Tcp/OT","6000"
^SCFG: "Tcp/WithURCs","on"
^SCFG: "Trace/Syslog/OTAP","0"
^SCFG: "URC/Ringline","local"
^SCFG: "URC/Ringline/ActiveTime","2"
^SCFG: "Userware/Autostart","1"
^SCFG: "Userware/Autostart/Delay","0"
^SCFG: "Userware/DebugInterface","0.0.0.0","0.0.0.0","0"
^SCFG: "Userware/DebugMode","on"
^SCFG: "Userware/Passwd",
^SCFG: "Userware/Stdout","usb4",,,,"off"
^SCFG: "Userware/Watchdog","0"

OK
/**************************** Sucessful Routine  *************************************************/

Java midlet Started.

$Transparent Socket v0.0
Sending asynchronous Command... 0
$InputStream and OutputStream opened
CMD_Config: ATE0

OK

Sending asynchronous Command... 1
CMD_Config: AT+CMEE=1

OK

Sending asynchronous Command... 2
CMD_Config: AT+CMEE=1

OK

Sending asynchronous Command... 3
CMD_Config: AT+CREG=2

OK

Sending asynchronous Command... 4
CMD_Config: AT+CGREG=2

OK

Sending asynchronous Command... 5
CMD_Config: AT+CPIN?

+CPIN: READY

OK

Sending asynchronous Command... 6
CMD_Config: AT+CLIP=1

OK

Sending asynchronous Command... 7
CMD_Config: AT+CMGF=1

OK

Sending asynchronous Command... 8
CMD_Config: AT+CREG?

+CREG: 2,1,"C937","00002894",0

OK

Sending asynchronous Command... 9
CMD_Config: at^SCFG="Tcp/WithURCs","on"

^SCFG: "Tcp/WithURCs","on"

OK

Sending asynchronous Command... 10
CMD_Config: AT^SISS=1,"srvType","none"

OK

Sending asynchronous Command... 11
CMD_Config: at^SICS=1,"conType",GPRS0

OK

Sending asynchronous Command... 12
CMD_Config: at^SICS=1,"inactTO","120"

OK

Sending asynchronous Command... 13
CMD_Config: AT^SICS=1,dns1,"8.8.8.8"

OK

Sending asynchronous Command... 14
CMD_Config: AT^SICS=1,passwd,""

OK

Sending asynchronous Command... 15
CMD_Config: AT^SICS=1,user,""

OK

Sending asynchronous Command... 16
CMD_Config: AT^SICS=1,apn,"internet.colombiamovil.com.co"

OK

Sending asynchronous Command... 17
CMD_Config: AT^SISS=1,"srvType","Socket"

OK

Sending asynchronous Command... 18
CMD_Config: AT^SISS=1,"conId","1"

OK

Sending asynchronous Command... 19
CMD_Config: AT^SISS=1,"address",socktcp://201.234.71.191:12000

OK

Sending asynchronous Command... 20
CMD_Config: AT+CGATT=1

OK

URC Message:
+CGREG: 1,"C937","00002894",3,"57"

URC Message:
+CGREG: 1,"C937","00002894",3,"57"

Sending asynchronous Command... 21
CMD_Socket: AT^SISO=1

Trying to establish Socket....

OK

URC Message:
^SISW: 1,1

$EVENT: Socket Established!

/***********************END OF ROUTINE*****************************/

After the power failure everything from command 10 (AT^SISS=1,"srvType","none") returns +CME ERROR: 256