Gemalto is now part of the Thales Group, find out more.

You are here

Failed to connect remote debugging device EHS5 | Thales IoT Developer Community

101422

December 24, 2018 - 9:19am, 730 views

Hello!

I use Elcipe provided with WTK. Tried to use newer versions of Eclipse, but nothing helps.

What could be the problem?

Debugging console displays:

Registering ip address "192.168.244.1" of remote debugging device...

Waiting for debug device registration of "IMP_NG_EHS5_REMOTE"...

Failed to connect remote debugging device!

Passing control to external device emulator...

End of debug session. Emulator is closed!

___

Terminal shows:

AT^SCFG?

^SCFG: "Call/ECC","0"

^SCFG: "Gpio/****/ASC1","std"

^SCFG: "Gpio/****/DAI","gpio"

^SCFG: "Gpio/****/DCD0","std"

^SCFG: "Gpio/****/DSR0","std"

^SCFG: "Gpio/****/DTR0","std"

^SCFG: "Gpio/****/FSR","gpio"

^SCFG: "Gpio/****/PULSE","gpio"

^SCFG: "Gpio/****/PWM","gpio"

^SCFG: "Gpio/****/RING0","std"

^SCFG: "Gpio/****/SPI","rsv"

^SCFG: "Gpio/****/SYNC","std"

^SCFG: "GPRS/AutoAttach","enabled"

^SCFG: "Ident/Manufacturer","Cinterion"

^SCFG: "Ident/Product","EHS5-E"

^SCFG: "MEopMode/SoR","off"

^SCFG: "MEShutdown/Fso","0"

^SCFG: "Radio/Band","147"

^SCFG: "Radio/OutputPowerReduction","4"

^SCFG: "Serial/Interface/Allocation","1","1"

^SCFG: "Serial/USB/DDD","0","0","0409","1E2D","0058","Cinterion Wireless Modules","EHx",""

^SCFG: "Tcp/IRT","3"

^SCFG: "Tcp/MR","10"

^SCFG: "Tcp/OT","120"

^SCFG: "Tcp/WithURCs","on"

^SCFG: "Trace/Syslog/Otap","0"

^SCFG: "Userware/Autostart","1"

^SCFG: "Userware/Autostart/Delay","100"

^SCFG: "Userware/DebugInterface","192.168.244.1","192.168.244.2","0"

^SCFG: "Userware/DebugMode","on"

^SCFG: "Userware/Passwd",

^SCFG: "Userware/Stdout","usb3",,,,"off"

^SCFG: "Userware/Watchdog","1"

OK

__