Gemalto is now part of the Thales Group, find out more.

You are here

Java compiler setting | Thales IoT Developer Community

Sharon

April 25, 2018 - 5:51am, 812 views

Hai! I understand that the correct Java compiler setting ( Compiler compliance level ) should be set to 1.3 or 1.4 (from Java User guide) , but, from what i get from my distributer is jdk 1.7.0.  So if i select 1.3 compliance, error occured because it's not compatible. Since i have already installed jdk 1.7.0, i would like to keep that instead of uninstall it and install jdk 1.3. Any solution can be done to avoid this? 

P.s: I'm doing midlet to access aws. When running the midlet, i get java.lang.Error: ClassFormatError:  56 which i think the problem occur due to my classpath.