Gemalto is now part of the Thales Group, find out more.

You are here

PLS62-W very slow data receiving with AT^SISR | Thales IoT Developer Community

August 5, 2020 - 11:01pm, 542 views

Hello,

We are trying to receiving TCP data from PLS62-W chip to our MCU using AT command AT^SISR, but got very slow speeds (less then 1 KB/s).
Investigating this, showed that PLS62-W response with quite huge delays:

mcu *****


It takes about 40+ ms to answer on AT^SISR=0,128 with ^SISR:0,128 and then another ~160ms to transmit data and answered with final OK.
UART baudrate is 115200, but we tried 460800 also - it speed up everything in average just for 5ms ***.

Also to exclude our program influence, we did try same thing with PLS62T-W external terminal sending AT^SISR=0,128 from Windows PuTTY terminal logging timed data and got same result (single LF - is pasted by PuTTY on logging):

putty log

As we can see 128 byte data transmission itself no so much delayed after ^SISR: 0,128, but final OK is gotten really latter.


It's quite surprisingly to see these from 4G ****m.

What is the reason of this issue? Thanks in advanced for help!