You are here

Receiving SMS URC trouble Firmware version

Toumoux

November 16, 2018 - 1:08pm, 157 views

Hello,

I have trouble to receive SMS on one of my two EHS6 module. I used the same Java Midlets for both of my module you can find it here https://developer.gemalto.com/tutorial/how-receive-sms-message .

For the module one all is working find, the JAVA API catch the urc and it’s written on the System.out Console.

The trouble appears on the second module with the same JAVA Midlets. The URC is not transmitted to the Java API and the Listener is never called.

The Autostart of the JRC is enabled of both of the module. Here are the following configurations of the two modules:

 MODULE 1, the one which works:

AT^SJAM=5

16/11/2018 11:42:21.522 [RX] - AT^SJAM=5<CR>

<CR><LF>

^SJAM: "a:/JRC-1.56.40.jad","Java Remote Control MIDlet Suite","Cinterion","1.56.40",1<CR><LF>

^SJAM: "a:/TestSMS.jad","TestSMS MIDlet Suite","MIDlet Suite Vendor","1.0.0",0<CR><LF>

<CR><LF>

OK<CR><LF>

AT^SJAM=4

 

16/11/2018 11:41:41.449 [RX] - AT^SJAM=4<CR>

<CR><LF>

^SJAM: "a:/TestSMS.jad","TestSMS MIDlet Suite","MIDlet Suite Vendor","1.0.0",0,48055,0<CR><LF>

^SJAM: "a:/JRC-1.56.40.jad","Java Remote Control MIDlet Suite","Cinterion","1.56.40",1,753963,0<CR><LF>

<CR><LF>

OK<CR><LF>

 

ATI1

 

16/11/2018 11:42:47.979 [RX] - ATI1<CR>

<CR><LF>

Cinterion<CR><LF>

EHS6<CR><LF>

REVISION 03.001<CR><LF>

A-REVISION 00.000.31<CR><LF>

<CR><LF>

OK<CR><LF>


 

MODULE 2, the one which doesn’t works:

AT^SJAM=5

16/11/2018 11:33:00.370 [RX] - AT^SJAM=5<CR>

<CR><LF>

^SJAM: "a:/JRC-1.56.54.jad","Java Remote Control MIDlet Suite","Cinterion","1.56.54",1<CR><LF>

^SJAM: "a:/TestSMS.jad","TestSMS MIDlet Suite","MIDlet Suite Vendor","1.0.0",0<CR><LF>

<CR><LF>

OK<CR><LF>

AT^SJAM=4

 

16/11/2018 11:35:25.143 [RX] - AT^SJAM=4<CR>

<CR><LF>

^SJAM: "a:/TestSMS.jad","TestSMS MIDlet Suite","MIDlet Suite Vendor","1.0.0",0,48055,0<CR><LF>

^SJAM: "SLAE.jad","SL Agent Module Services","Gemalto M2M GmbH","2.1.1",0,422843,0<CR><LF>

^SJAM: "a:/JRC-1.56.54.jad","Java Remote Control MIDlet Suite","Cinterion","1.56.54",1,789491,0<CR><LF>

<CR><LF>

OK<CR><LF>

ATI1

 

16/11/2018 11:35:57.821 [RX] - ATI1<CR>

<CR><LF>

Cinterion<CR><LF>

EHS6<CR><LF>

REVISION 03.001<CR><LF>

A-REVISION 00.000.51<CR><LF>

<CR><LF>

OK<CR><LF>

I have read that a possible problem can be the JRC firmware version which is used to receive ATCommand URC. And in my case the version on each module is different!

Does someone know if the newest version JRC-1.56.54 has this kind of trouble?

Moreover one the module which doesn’t work there is the SLAE.jad file which is installed and I was wondering the use of this file?

Thanks for reading and have a nice day ! :)