Gemalto is now part of the Thales Group, find out more.

You are here

^SIS: 0,0,2200,"HTTP POST Response: -1 | Thales IoT Developer Community

July 30, 2021 - 7:07am, 265 views

Hello,

>>ATI1

Cinterion
EHS5-E
REVISION 03.001
A-REVISION 00.000.14
OK.

Instead of default timeout of 6000, I have been using 180sec as a timeout for each connection at^siss=1,"tcpOT",180 after timeout response for post is ^SIS: 0,0,2200,"HTTP POST Response: -1.

Here if we consider the post was successful then response for read is ^SISR: 1,-2. Frequency of issue is unpredictable but once it occurs it takes lot of time to recover even after soft and Hard reset.

Please refer below for more info and do suggest the needful to fix the issue.
Note: URL, IP, PORT are not disclosed.

>>AT^SISW=1,0,1

^SISW: 1,0,0
OK
^SISW: 1,2
^SIS: 1,0,2200,"HTTP POST: URL"
^SIS: 1,0,2200,"HTTP POST Response: -1"
^SISR: 1,2

>>AT^SISR=1,300

^SISR: 1,-2
OK

>>at^siso?

^SISO: 0,""
^SISO: 1,"Http",6,1,0,242,"0.0.6.40:0","IP:PORT"
^SISO: 2,""
^SISO: 3,""
^SISO: 4,""
^SISO: 5,""
^SISO: 6,""
^SISO: 7,""
^SISO: 8,""
^SISO: 9,""

OK

>>at^sici?<CR>

^SICI: 1,2,1,"10.103.36.40"
OK

>>at^siss?<CR>

^SISS: 0,"srvType",""
^SISS: 1,"srvType","Http"
^SISS: 1,"conId","1"
^SISS: 1,"address","URL"
^SISS: 1,"tcpMR","10"
^SISS: 1,"tcpOT","180"
^SISS: 1,"cmd","post"
^SISS: 1,"hcContLen","242"
^SISS: 2,"srvType",""
^SISS: 3,"srvType",""
^SISS: 4,"srvType",""
^SISS: 5,"srvType",""
^SISS: 6,"srvType",""
^SISS: 7,"srvType",""
^SISS: 8,"srvType",""
^SISS: 9,"srvType",""
OK

>>AT^SISC=1

OK